WhiteBlaze Pages
A Complete Appalachian Trail Guidebook.
$10 for printed copy(paperback). $6 for interactive PDF. $2 for printable PDF.
Read more here WhiteBlaze Pages Store

Page 2 of 2 FirstFirst 1 2
Results 21 to 27 of 27
  1. #21

    Default

    Maybe there's just a ton of variation from one unit to the next. I carried a Mini on one week long trip years ago and it took forever to filter a bottle at a time. I never used it again afterwards. The BeFree that I've got now must filter at least 3-4 times faster.

  2. #22

    Default

    Quote Originally Posted by CalebJ View Post
    Maybe there's just a ton of variation from one unit to the next. I carried a Mini on one week long trip years ago and it took forever to filter a bottle at a time. I never used it again afterwards. The BeFree that I've got now must filter at least 3-4 times faster.
    Thats probably true, the first mini I had performed as you observed. Before I knew to try vinegar to unclog the filter (or any other methods) I figured I must have damaged it in the pack and purchased an identical replacement that worked much better. Haven't had a problem since as long as I back flush it periodically and run a little vinegar through it.

  3. #23
    Registered User
    Join Date
    02-01-2016
    Location
    Chattanooga, Tennessee
    Posts
    984

    Default

    minor point of clarification - when I have backflushed the mini with distilled water before leaving (or soaked with vinegar to enable that), I bring the mini wet, not dried out. Even if it's clear of mineral build-up, it can be slow to get going if it's completely dry when you start to use it in the field. It gets going much easier and quicker if it's already a bit wet.

  4. #24

    Default

    Quote Originally Posted by Traveler View Post
    Thats probably true, the first mini I had performed as you observed. Before I knew to try vinegar to unclog the filter (or any other methods) I figured I must have damaged it in the pack and purchased an identical replacement that worked much better. Haven't had a problem since as long as I back flush it periodically and run a little vinegar through it.
    Quote Originally Posted by Time Zone View Post
    minor point of clarification - when I have backflushed the mini with distilled water before leaving (or soaked with vinegar to enable that), I bring the mini wet, not dried out. Even if it's clear of mineral build-up, it can be slow to get going if it's completely dry when you start to use it in the field. It gets going much easier and quicker if it's already a bit wet.
    Nice tips with the vinegar and distilled water, will have to try it out. Also would be nice to try the other filters to know how fast the flow can be as we didn't realize that the Mini one is on the slow side.

  5. #25
    Registered User
    Join Date
    02-01-2016
    Location
    Chattanooga, Tennessee
    Posts
    984

    Default

    Another clarification - if you have to use vinegar to clear out your filter, follow that up with distilled water. Else you might get a vinegar taste for your first filtering! :P

  6. #26
    Registered User
    Join Date
    10-17-2007
    Location
    Michigan
    Age
    62
    Posts
    4,906

    Default

    For years I have seen reports of Sawyer filters giving highly variable results. I have found that curious and wondered what may be the explanation. One possible answer may be the way these filters respond to air. This comes from my science career where I have used filters in the lab to sterilize solutions that cannot survive autoclaving. We use thin filter disks with a 0,2 micron pore size (same as Sawyer). These disposable disks go into a two part holder that screws together with an O ring gasket to make sure the solution goes through and not around the filter. The holder attaches to a syringe. You pour the solution into the syringe and push it through with the plunger into a sterile test tube. Occasionally the filter will rip or the gasket leaks in which case your solution will not be sterile. To avoid ruining your experiment, you always test the integrity of the filter. To do this you only fill the syringe half full. Then when your solution has gone through you keep pushing. If the filter is intact, the air in the syringe will not go through, no matter how hard you push the plunger. It is curious, but air will go through a dry filter but will not go through a wet filter. I don't know why. But I have observed my Sawyer filter behaving the same way. If I half fill my dirty water bladder, after filtering I find I am not able to squeeze the air through the filter. I take this as a sign that my filter is still in intact. People usually blame their slow filter rates on clogged filters. I sometimes wonder if trapped air bubbles may be the culprit, especially when people have poor performance with filters that are nearly new.

  7. #27

    Default

    I made this video about a year ago where I compare a new Squeeze to a new Mini to a 5 year old Squeeze. The Mini is clearly slower and not as effective as the Squeeze.

Page 2 of 2 FirstFirst 1 2
++ New Posts ++

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •